Nexthink Service Degradation: DEX score is not visible

Incident Report for cnu-nxt.statuspage

Resolved

We are pleased to confirm that the DEX Score visibility issue is fully resolved. Thank you for your patience.
Posted Jul 09, 2025 - 11:52 UTC

Monitoring

The DEX Score visibility issue has been fixed and will be under monitoring for sometime. We appreciate and thank you for your patience.
Posted Jul 09, 2025 - 09:59 UTC

Update

Our team is continuing to work on resolving the issue affecting the visibility of the DEX score. We are making steady progress and remain focused on restoring full functionality as soon as possible.
Posted Jul 09, 2025 - 09:31 UTC

Investigating

We are aware of a degraded performance issue impacting the Experience Central product, causing the DEX score to be temporarily invisible. Our engineering team is working diligently on fixing it. We thank you for your patience.
Posted Jul 09, 2025 - 07:49 UTC