Nexthink Service Degradation: DEX score is not visible

Incident Report for cnu-nxt.statuspage

Resolved

We can confirm that the DEX Score visibility issue has been fully resolved. We appreciate your patience during this time.
Posted Jul 11, 2025 - 07:59 UTC

Monitoring

The DEX Score visibility issue has been fixed and will be under monitoring for sometime. We appreciate and thank you for your patience.
Posted Jul 10, 2025 - 08:54 UTC

Update

Our team is continuing to work on resolving the issue affecting the visibility of the DEX score. We are making steady progress and remain focused on restoring full functionality as soon as possible.
Posted Jul 10, 2025 - 08:36 UTC

Investigating

We are currently experiencing a recurrence of the degraded performance issue affecting the Experience Central product which results in the DEX score temporarily not visible for some users. Our engineering team is working diligently on fixing it. We thank you for your patience.
Posted Jul 10, 2025 - 06:59 UTC